This project has moved and is read-only. For the latest updates, please go here.

Renaming folder on network share

Aug 26, 2012 at 5:41 PM

Hi, I just started using this product and am running into a problem.  I'm pooling two HDD's on a computer running Windows 7 that is then sharing out the pool across my network to another Windows 7 computer with full control.

The problem is when I try to rename a folder on the client computer, it gives me an error saying "could not find this item.  It is no longer located in..."

When I try it on the computer that is running the pool locally, it works fine.



Aug 26, 2012 at 5:43 PM

Should add I also cannot delete files on client computer with same error.

Aug 26, 2012 at 6:01 PM

Am using x64 and default settings, tried Dokan thread at 0, and using the folder merge mode.  Tried restarting the config but still cannot rename/delete things on client computers.

Aug 27, 2012 at 7:38 AM

This sounds "similar" to the following issues, can you have a look at them to see if they are the same, if not I will need logs, config files and the version you installed please.



A rename is a like the move operation: ""

Aug 27, 2012 at 4:53 PM

Hi, thanks for the reply.  I'm at work right now so I'll try to get you the info later.  What I can tell you is:

1.  Server here is Windows 7 Ultimate x64.  Client is Windows 7 Home Premium x64.  Brand new server install with basic software and updated drivers.
2.  Consistently will never let me do a rename/move/delete on the client computer with a share that gives full access.  Works fine on server.
3.  Got a few BSODs that I think are tied to this software because after disabling the service it has been stable.
4.  Tried Flexraid drive pooling and it does not exhibit this problem and does not BSOD.  According to my research, it uses a different component under-the-hood.

Will throw it back on later and take some screenshots and upload the log.  The config was pretty basic.  2 mount points: (c:\mount\data1, c:\mount\data2).




Aug 28, 2012 at 7:04 PM

1) What version of Liquesce have you installed?
2) Only "seen" the issues as stated in the links I have given when done from the "Root" of the share
3) Never seen a BSOD, so not sure what you are seeing there.
4) Yes, FlexRaid "Dropped" dokan a while ago, and went over to CBFS, which is probably why it needs to be paid for now.

Can you go through the steps to create clean logs and attach to the issue that will follow this Post:

To help with diagnostics, I need the following
- Your Config File
- Logs with threads set to 1 and level set to Trace (When changing these remember to send to the server and then restart)
- A timestamp to look for in the log file when telling µTorrent to download a new file
- Attach to the "Issue" that will be noted @ after this post.

The logs can be obtained via here:

Aug 28, 2012 at 7:05 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Nov 27, 2012 at 6:26 PM

I tried to workaround this in the Phase I code stream (Dokan) but had no luck.

So, going forward with Phase I, I have decided to remove my support for any Network sharing;

I shall try to re-establish this in in Phase II, but that will be released (probably in) Q1 2013.