This project has moved and is read-only. For the latest updates, please go here.

Problems sharing a drive

Mar 22, 2012 at 3:23 AM


I'm having a rather frustrating problem with Liquesce.  I'm attempting to share out my drive to various machines and media players in my house.  My Linux XBMC machine connects fine.

When trying to access the shared drive through Network Neighbourhood on my Windows XP PC I get the following error: "\\ServerName\z is not accessible.  You might not have permissions to use this network resource..." even though granted Full Control to Everyone, as well as 2 other user IDs that I've created.

When trying to connect with my Western Digital TV Live player, it sees the server and the drive, but when I click on the drive it says there is no content (even though there is about 3 TBs of media). 

Also, I have shared out a couple of the individual drives that make up the pooled drive, and I am able to connect to them with no problems from all machines.

I'm stumped!  I just installed the newest version, but still nothing.  My settings are as follows:

Dokan Debug - True

Thread Count - 1

Disk Allocation - Priority

File Detail Cache - 32

Hold Off Buffer - 1024

Service Logging Level - Debug

This is running on an XP Pro SP3 machine.  Any help that can be offered would be greatly appreciated.


Mar 22, 2012 at 8:03 AM

Just to confirm.. Liquesce is on XP SP3 ?

And XBMC can see the share that is set up.

But other machines (Of which OS) cannot, is that after a reboot of the liquesce machine ?

Have you read the following (Just in case it works on XP) ""

Do you have a Virus scanner or firewall combination that may be blocking the access to the drive (As it is not the same as a physical drive, therefore would not be there when they are started on machine power up)?

Mar 22, 2012 at 4:30 PM

Liquesce is running on XP Pro SP3.

XBMC (running on Linux) can see the share and play the media that is on it.

My PC (running XP SP3) cannot connect and gets the error that the drive is not accessible.  My Western Digital Live media player (which I think runs some sort Linux?) can see the drive, but can't see any media on it.  I have tried rebooting the liquesce machine several times, and I've also tried shutting off all of the machines connecting except one, just in case there is some sort of conflict or limit to how many machines can connect.  None of that seemed to help.

I have read the link, but I haven't tried it.  I will give it a shot tonight and report back.

No virus scanner on the Liquesce machine, and the windows Firewall is completely disabled.

Thanks for the help!


Mar 22, 2012 at 7:03 PM

Thanks for the update, So what I can test is XP to XP, I'll move this to an Issue.

If you can attach the zipped log file (to the issue) and the time at which the share connect attempt was made (and show that the XBMC has also connected) that would be helpful. (Change the Logging setting to Trace before and reboot please)


Mar 22, 2012 at 7:05 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.