This project has moved. For the latest updates, please go here.

Network Shares and XBMC

Aug 3, 2012 at 2:16 PM
Edited Aug 3, 2012 at 2:20 PM

I've been using Liquesce since the start of the year to use on multiple TB drives in order to have a single drive shared on a Windows network in order for easier access. It has been working great.. up until about a month ago.

I first started noticing an issue while using my main XBMC box, an Intel ATOM ION machine. It has been acting as if the frames in large videos, at first 1080p but now 720p too, have been skipping, giving a pixeled effect which seems to be getting worse over the last few weeks. Trying to problem solve the issue I decided to try sharing one of the drives directly. Played a video that had the issue and it was fine, no problems, played perfect. But every time I try a video from the pooled shared drive it gives the same issue. It is as if the video isn't loading fast enough.

I tried to copy the file to the desktop to see what the network speeds would be, once from the pooled share and once from the drive shared. Oddly, the ATOM wouldn't really copy, locked up and went extremely slow, gave up. I tried the same on my laptop, which has Teracopy by the way and is connected the same way the ATOM machine is. It went at the same speed both times, around 10MB/s, which is the speed of the laptops NIC and should be fast enough to stream these videos. Even if it wasn't fast enough, it is still odd that XBMC has no issue with the same file shared directly from the drive but does with the pool.

On another note, while searching for a solution I came across this thread.

http://liquesce.codeplex.com/discussions/241280

I was going to attempt something mentioned, "Manually edit the client.configuration file and change the "BufferWireTransferSize" to be a larger value." I cant find a "client.configuration" anywhere on the PC or anything to do with "BufferWireTransferSize" in any of the config files related to Liquesce.

Another thing is I'm not the only one having this issue. A friend of mine basically has a copy of my setup at their house, a computer with multiple TB pooled drives, pooled shared, and a XBMC box (though much more powerful than mine) accessing the pool. She is just starting to get the same issue as I am so it isn't just me and my hardware, the only thing linking our cases is Liquesce and XBMC. I will be asking her to use another program, like VLC or WMP to see if the issue persists in those programs too.

Coordinator
Aug 3, 2012 at 8:07 PM

XBMC I cannot test, so would be interested in what settings you are using and some logs files please.

BufferWireTransferSize was for my attempt to work around the sharing problems of Dokan, by implementing an FTP Client (See Amalgam) and Frontend Service to Liquesce. So in your case it will not be applicable.

 

To help with diagnostics, I need the following,
- Your Config File
- Logs with threads set to 1 and level set to Trace (When changing these remember to send to the server and then restart)
- A timestamp to look for in the log file when telling XBMC to download a new file
The logs can be obtained via here: http://liquesce.codeplex.com/wikipage?title=How%20To%20Get%20Logs&referringTitle=FAQs

Aug 4, 2012 at 9:41 AM

Both GUI and Service logs?

Would it make things easier if I started new logs?

Since I am using sharing, wouldn't these issues Dokan has still effect me?

Coordinator
Nov 27, 2012 at 6:26 PM

2) I tried to workaround this in the Phase I code stream (Dokan) but had no luck.

So, going forward with Phase I, I have decided to remove my support for any Network sharing;

I shall try to re-establish this in in Phase II, but that will be released (probably in) Q1 2013.